3
$\begingroup$

I'm building a drone with arducopter 2.8 (ArduCopter V3.2.1) and I'm using the DSHot 600 (BLHELI_S) Opto ESC's as my ESC and when I connect the Opto ESC to the arducopter and arducopter to the receiver the motor is not responding to the throttle movements.

When I connect the battery the ESC beeps (First three beeps (Cause I'm using 3s Battery).

I'm not sure why this happens if the ESC beeps then why the motor is not responding to the throttle.

To ensure I checked whether it's the radio problem and I ran the radio calibration and each sticks works properly but the motor is not responding to movements it just beeps and no movement.

I'm struggling with this issue for the past two weeks looking for a perfect solution but none of them is related to my issue.

$\endgroup$
7
  • $\begingroup$ Have you calibrated the throttle range? Look in your ESC manual for the meaning of the number of beeps it plays. $\endgroup$ Jun 18 at 22:07
  • $\begingroup$ Look the section 5.4 of this manual. $\endgroup$ Jun 18 at 22:13
  • $\begingroup$ Yes, I calibrated the ESC and I actually connected the ESC directly to the receiver, and when pushed the throttle the motor is not running smoothly and at one time motor gets heated and smokes. $\endgroup$ Jun 19 at 9:09
  • $\begingroup$ Something similar has already happened to me and the problem was with the ESC. Can you test each one using another ESC and Motor? $\endgroup$ Jun 20 at 22:21
  • $\begingroup$ Each goes like same when I tried connecting the motor is not smoothly moving and breaks in between actually the motor is not moving as previous. ESC heats up after few seconds. $\endgroup$ Jun 21 at 2:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.