5
$\begingroup$

I build a quad using Mamba F405 MK2 stack 40A ESC's and XING-E 2207 motors.

Here are some pictures of my configurations on Betaflight and BLHeli Configurator:

https://imgur.com/a/mFLDiVp

Also video of issue in Reddit:

https://www.reddit.com/r/Multicopter/comments/inphxg/why_is_this_happening_with_my_motors/

I used to have two issues:

I set Bidirection Dshot with 4khz PID loop freq and because using F4 FC I had to change to Dshot300. Then when trying to set little bit the Throttle after arming the quad the motors suddently spin super mega fast (very dangerous).

When I arm the quad the motors start spinning even that I have set not to spin when armed.

What I did for the first issue is to remove bidirectional dshot. Seems that because the ESC only support Dshot 600 when I set Dshot 300 it start behaving pretty bad.

Any clue if using F4 flight controller I can use Dshot600 with bidirectional dshot?

Also any clue on how to solve the start spinning motors thing?

Thanks

$\endgroup$
6
  • $\begingroup$ Doesn't the BLHELI Configurator not work properly with BLHeli32 ESCs? I thought you had to use BLHELI_suite $\endgroup$
    – ifconfig
    Sep 7 '20 at 2:35
  • $\begingroup$ No, for BLHeli_S you have to use BLHeli Configurator. There is no other way. :) But works pretty good. $\endgroup$
    – VAAA
    Sep 7 '20 at 2:55
  • 2
    $\begingroup$ Oh wait... have you flashed custom firmware to your BLHELI_S ESCs or are you running them stock with the latest official release? $\endgroup$
    – ifconfig
    Sep 7 '20 at 3:11
  • $\begingroup$ Actually I downloaded the HEX file 16.73 for BLHeli_S and seems that fixed the issue. THe only issue pending is that my motors spin when armed at min throttle with Angle mode. I saw that pid_at_min_throttle was ON so I just set it to OFF and I will try today. $\endgroup$
    – VAAA
    Sep 7 '20 at 14:12
  • $\begingroup$ Well that shouldn't be working either... stock BLHELI_S firmware doesn't support bidirectional DSHOT. $\endgroup$
    – ifconfig
    Sep 7 '20 at 16:30
1
$\begingroup$

If you have airmode enabled as a feature then the motors will spin on arm no matter what other settings you have.

It sounds to me like you may have accidentally set your ESC's to bi-directional in BL-heli configurator which is NOT the same as bi-directional DSHOT protocol. Check out this video for explanation on the difference : https://www.youtube.com/watch?v=DXfAnCLr3q0&t=65s

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.