5
$\begingroup$

This is related to my past ESC troubles. See link for some flight history.

I tried the recalibration as suggested by ifconfig, which sadly didn't work. But now the motor will not go above 2/3rds thrust(slight improvement), no matter the calibration range. I did do one calibration where I used full throttle as max and the center as none, and the ESC would stop working once I got above 2/3rds of the calibration range.

What it is not;

  • ESC overheating/overloading(it is cool to the touch and I even ran it in our deep freezer, same results)
  • broken ESC(I used a new ESC as well as an old one I fixed. Both have the same problem)

What I'm not sure about;

  • the receiver has been in some crashes, perhaps it got shaken around and is messing with the signals?
  • the transmitter is cheap so it might be messed up, but it was working fine before.
  • motor might be broken but I don't think so, it's not even scratched up.
  • battery(charger) might be to blame. The charger I have (also cheap) has 3 lights for the cells, and the cell 1 light never turns green(ive left it charging overnight, still red). I just thought the charger was broken, but maybe cell 1 isn't getting charged?

hardware specs;

  • ESC is rated for 30A, uses T-plug to connect to battery.
  • Battery is a 3S 2200 mah 30C from Mirahobby
  • Motor is 2200 kv, is using a 9050 prop(slightly outside plane and motor recommendations)
  • Plane is an FT Spitfire from flitetest
  • The only modifications I have made to any of these pieces is when I globbed some hot glue onto the antennae on the receiver to strengthen it some

What do I need to fix to get the motor/esc to work properly? Do I need to replace any of my hardware? Should I just build a lighter plane that only needs 2/3 thrust?

$\endgroup$
7
  • 1
    $\begingroup$ Do you have a multimeter? If so, could you test to make sure that a fully-charged battery is 4.2V*[cell count]? $\endgroup$ – ifconfig Dec 9 '20 at 18:10
  • $\begingroup$ @ifconfig, I used to have a multimeter, but it broke when i used it to test an electric fence(tip; don't do that). I have yet to purchase a new one. also I will add in the cell count, thx for reminding me of that. $\endgroup$ – Ceramicmrno0b Dec 9 '20 at 18:39
  • 1
    $\begingroup$ Okay, well you could also check the transmitter endpoints to confirm that the TX/RX are outputting full-range values. $\endgroup$ – ifconfig Dec 9 '20 at 18:55
  • 2
    $\begingroup$ A possibility is that one of the cells of the battery is damaged and cannot supply enough current which results in the ESC cutting out when it draws too many amps. $\endgroup$ – Jacob B Dec 10 '20 at 4:00
  • 1
    $\begingroup$ You really need to try a different battery, especially as it's not charging properly. Maybe even a 12v car battery? $\endgroup$ – Robin Bennett Dec 10 '20 at 8:32
2
$\begingroup$

It was the battery.

Bought a new battery, charged it, all 3 lights turned green, and motor/esc has no trouble going to full thrust. Lots of power now, so that should really help the plane fly.

Problem solved!

And on the bright side, I get to tear apart the broken 3s battery and see how to fix it or turn it into a 2s. I'll probably put a question on electrical engineering SE about that later.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.