3
$\begingroup$

I fixed the esc of my aircraft, but now it won't go above half thrust for whatever reason. Here is a short record of the electronics in the craft;

Crashed twice, broke esc, soldered 3-pin ground connector back to the esc, wrapped in electrical tape, worked fine, all seemed good, now won't go above 1/2 thrust.

When I go above half thrust, the motor will stop spinning, and the plane will beep a few times. After about 3-5 seconds, if I pull the throttle back down to 0 and then push back up, it will resume spinning but still will not go above 1/2 thrust.

I do have a new esc on the way from amazon so that might fix it but still have no idea why the plane won't go above half thrust. Any idea why and how to fix it?

Plane has 1 motor, rudder, and elevator in use. Ailerons were not connected for the flight when I noticed it would not go above half thrust.

$\endgroup$
4
  • $\begingroup$ Are your ESCs using PWM control or a digital protocol like DSHOT? $\endgroup$
    – ifconfig
    Nov 29 '20 at 18:37
  • $\begingroup$ @ifconfig, they use pwm $\endgroup$ Nov 29 '20 at 18:37
  • 1
    $\begingroup$ This sounds like a miscalibration issue to me. Are you familiar with how to recalibrate a PWM ESC's high and low throttle signals? $\endgroup$
    – ifconfig
    Nov 29 '20 at 18:54
  • $\begingroup$ @ifconfig, nope. $\endgroup$ Nov 29 '20 at 19:23
7
$\begingroup$

This sounds very much like like a PWM/analog ESC miscalibration issue to me. PWM ESCs required signal calibration to ensure that both the RC receiver and the ESC are on the same page about what kind of pulse length constitutes both 0% and 100%, as there can be clock speed discrepancies and other issues with the protocol.

enter image description here

I can't exactly find a source I like for this procedure to explain it better, so here's my rendition: (modified from those listed here)

  1. With ESC power unplugged, connect the ESC signal to the receiver's throttle channel.
  2. Turn on the transmitter and receiver and move the throttle to 100%.
  3. Enable power to the ESC and wait for it to beep a few times indicating it's in calibration mode.
  4. Briskly lower the throttle channel to 0% and wait for the ESC to beep to indicate it's now calibrated
  5. Try to operate the ESC like normal and see if the full-throttle range has been restored
$\endgroup$
3
$\begingroup$

That could also be a lipo that has been over-discharged or for some other reason is just not able to provide as much current as it used to.

The way to check (assuming you don't have a 'known-good' battery for comparison) is to measure the voltage when you open the throttle. If it drops below 3v per cell and then cuts, it's definitely the battery. If the battery voltage hardly changes but the motor still cuts out, the problem is elsewhere.

$\endgroup$
1
  • $\begingroup$ Hrm, interesting idea! I'm curious how this explains the ESC fault though. $\endgroup$
    – ifconfig
    Nov 30 '20 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.