3
$\begingroup$

After I figured out why SAFE never turned off, now I'm stuck because my motor won't spin and I can't enter calibration mode of the ESC. After turning on the plane, it does three startup beeps in ascending order, then the receiver wobbles the servos a bit as it calibrates, and then I can move the servos but the throttle doesn't work. After this the ESC stays quiet. This doesn't change regardless of throttle stick position.

The weird thing is that some of the time, everything works (1 in 10 times maybe, although it hasn't worked for a long time). And when it does work, it works perfectly fine. It's either all or nothing, which makes me doubt that there's a single piece of equipment that's broken - maybe it's just starting up wrong?.

Maybe it's an issue with a bad solder joint/wire to the motor - when it does work, the motor starts up jumpily and vibrates a lot - but I'm doubtful. On an occasion where I did get it working, I tried disconnecting each of the three ESC-motor cables, and the result was the same for each - the motor stuttered and didn't spin at all.

Maybe it's an issue with the ESC detecting my throttle is not at the low point on startup and refusing to run the motor. I moved the throttle trim to the bottom with no result. The ESC manual says that it will beep every 0.25 seconds in that case anyway (and it wasn't beeping).

One possibility is that I screwed up the calibration (e.g. by setting it to have 0 or infinite throttle range) beforehand and now I can't recalibrate it - I'm not sure if calibration affects the points used to calibrate it in future.

Equipment:

  • EFLR310013 receiver with SAFE and AS3X
  • Hobbywing 50A esc (manual)
  • Spektrum DXS transmitter (which works fine with other aircraft)
  • Unbranded large brushless motor
  • 25A, 1000mAh 3 cell battery (fully charged)

Battery is connected to ESC with a JST to EC3 adapter. ESC connects to motor with 3 large bullet-style plugs (one male plug is slightly larger diameter but still fits in with good contact). ESC is plugged into throttle port of receiver with servo-style cable.

I don't know the specifics of much of this equipment because I was "gifted" this plane partially damaged and most of the components aren't stock.

And no, this isn't an issue with the throttle cut switch on my transmitter (got tricked by that in my first plane)

Edit: I think the term for this is that it doesn't arm.

I also tried plugging the ESC into the elevator port and a servo into the throttle port. The servo moved fine with the throttle so there's not a connection issue there.

$\endgroup$
9
  • $\begingroup$ "I moved the ." <-- I think something might be missing here. $\endgroup$
    – Jacob B
    Nov 21, 2021 at 18:22
  • $\begingroup$ I was just discussing the throttle trim. Edited the question to fix. $\endgroup$ Nov 21, 2021 at 22:36
  • $\begingroup$ Ah okay! Thanks for updating. $\endgroup$
    – Jacob B
    Nov 21, 2021 at 22:55
  • $\begingroup$ Hi Mate please check your trottle trim, maybe is off the zero position or worse toward the throttle up position, that will prevent the esc to calibrate. Please check that, thanks. $\endgroup$ Nov 22, 2021 at 17:36
  • $\begingroup$ "I moved the throttle trim to the bottom with no result" I also tried the middle and the top but this still didn't let the ESC calibrate. $\endgroup$ Nov 22, 2021 at 20:40

1 Answer 1

2
$\begingroup$

Well I found a really roundabout solution that sorta works. Turn the ESC on not connected to receiver. Turn Tx on with throttle at max. Plug ESC into receiver. Then I can calibrate the throttle and the plane works. Unfortunately I have to do this every time I turn the plane on so this is not a permanent solution and thus I'm keeping the question open.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.