7
$\begingroup$

I've recently have an issue with my quad. One of my motor don't spin if I raise throttle too rapidly. If i raised it slowly i the motor turn correctly.

Only one of my motor have this issue and i've already change it but the problem is still here. Maybe it come from the esc but maybe someone have a solution ?

My Esc are configurate to use DSHOT300 (i've tried 150 but same probleme)

$\endgroup$
5
  • $\begingroup$ Wait, so are you saying that replacing the motor fixed the problem? $\endgroup$ – ifconfig Jun 3 at 16:59
  • $\begingroup$ No replacing the motor didn't change anything. I'll edit my question $\endgroup$ – Ruokki Jun 3 at 17:05
  • 2
    $\begingroup$ Have you tried swapping two motors around between the arms? This would help narrow down an ESC or motor issue. $\endgroup$ – ifconfig Jun 3 at 17:08
  • 1
    $\begingroup$ Not yet that's a good idea. I'll try it later (I don't have the time now to do that) $\endgroup$ – Ruokki Jun 3 at 17:10
  • $\begingroup$ I've swapped the 2 motor and i've still have the issue on the same esc . So i think this come from the ESC. $\endgroup$ – Ruokki Jun 6 at 20:41
2
$\begingroup$

Check the 'advance' setting on the ESCs. It controls when power is sent to each coil as it passes a magnet. It's usually somewhere between 0 and 20 degrees. Higher values mean that power is applied for longer but setting it too high will cause problems when accelerating quickly.

There's a windows tool - BLHeliSuite

Or a chrome plugin - BLHeli - Configurator

I just noticed that in the screen print, 'advance' is called 'motor timing' and has values like 'high/medium/low' rather than degrees.

$\endgroup$
3
  • $\begingroup$ Thanks for yor answer but how can i check this parameter ? $\endgroup$ – Ruokki Jun 4 at 10:25
  • $\begingroup$ I've trie motor range but it doesn't change the result $\endgroup$ – Ruokki Jun 6 at 20:06
  • 1
    $\begingroup$ @Ruokki - I've added links to the configuration tools for BLHeli ESCs (which most are). Note that there are a few different versions of BLHeli firmware. $\endgroup$ – Robin Bennett Jun 7 at 7:48
2
$\begingroup$

Thanks to the different answer

After the proposition from ifconfig in the comment, I've swapped 2 motors and have the issue have remained on the same arm. So the issue was comming from he esc.

I've tried to change conf on the esc as Robin have recommended without result.

So i've buyed new esc and replace it and everythinh work fine.

But by curiosity I cut the plastic film of the esc and I discovered that a component was broken (a light grey cube, I think it's a capacitor but I let the experts correct me). It fell out when I opened the plastic.

I don't know what it's for but maybe someone will have the same problem and can use my experience

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.