3
$\begingroup$

I have turned off all beeper sound signals in Betaflight Configurator, but the beeper still beeps if the transmitter is turned off. I thought that that shouldn't happen when RX_LOST was turned off or not paired, but maybe I have understood it wrong? Or is a bug or a problem with my setup in some way?

Here is my diff all:

# 

# diff all

# version
# Betaflight / STM32F405 (S405) 4.1.5 Mar 16 2020 / 05:19:58 (d4e74e39c) MSP API: 1.42
# manufacturer_id: AIRB   board_name: OMNIBUSF4SD   custom defaults: YES

# start the command batch
batch start

# reset configuration to default settings
defaults nosave

board_name OMNIBUSF4SD
manufacturer_id AIRB
mcu_id 003c00403436511339373635
signature 

# resources
resource SERIAL_TX 1 NONE
resource SERIAL_TX 11 A09

# feature
feature SOFTSERIAL
feature TELEMETRY

# beeper
beeper -GYRO_CALIBRATED
beeper -RX_LOST
beeper -RX_LOST_LANDING
beeper -DISARMING
beeper -ARMING
beeper -ARMING_GPS_FIX
beeper -BAT_CRIT_LOW
beeper -BAT_LOW
beeper -GPS_STATUS
beeper -ACC_CALIBRATION
beeper -ACC_CALIBRATION_FAIL
beeper -READY_BEEP
beeper -DISARM_REPEAT
beeper -ARMED
beeper -SYSTEM_INIT
beeper -ON_USB
beeper -BLACKBOX_ERASE
beeper -CRASH_FLIP
beeper -CAM_CONNECTION_OPEN
beeper -CAM_CONNECTION_CLOSE
beeper -RC_SMOOTHING_INIT_FAIL

# map
map TAER1234

# serial
serial 0 64 115200 57600 0 115200
serial 2 2048 115200 57600 0 115200
serial 5 16384 115200 57600 0 115200
serial 30 32 115200 57600 0 115200

# aux
aux 0 0 0 1700 2100 0 0
aux 1 1 3 1300 1700 0 0
aux 2 13 2 1300 1700 0 0
aux 3 35 2 1700 2100 0 0
aux 4 36 1 1700 2100 0 0
aux 5 39 3 900 1300 0 0

# rxrange
rxrange 0 987 2011
rxrange 1 987 2011
rxrange 2 987 2011
rxrange 3 987 2011

# vtxtable
vtxtable bands 6
vtxtable channels 8
vtxtable band 1 BOSCAM_A A FACTORY 5865 5845 5825 5805 5785 5765 5745    0
vtxtable band 2 BOSCAM_B B FACTORY 5733 5752 5771 5790 5809 5828 5847 5866
vtxtable band 3 UNKNOWN  U FACTORY    0    0    0    0    0    0    0    0
vtxtable band 4 FATSHARK F FACTORY 5740 5760 5780 5800 5820 5840 5860    0
vtxtable band 5 RACEBAND R FACTORY    0    0 5732 5769 5806 5843    0    0
vtxtable band 6 IMD6     I CUSTOM  5732 5765 5828 5840 5866 5740    0    0
vtxtable powerlevels 2
vtxtable powervalues 0 1
vtxtable powerlabels 25 200

# master
set gyro_sync_denom = 2
set dyn_notch_range = LOW
set dyn_notch_width_percent = 0
set dyn_notch_q = 200
set dyn_notch_min_hz = 90
set acc_trim_pitch = 4
set acc_trim_roll = -6
set acc_calibration = 40,-16,-19
set min_check = 1010
set max_check = 1990
set rssi_channel = 9
set serialrx_provider = SBUS
set dshot_bidir = ON
set motor_pwm_protocol = DSHOT300
set vbat_scale = 108
set small_angle = 180
set pid_process_denom = 1
set osd_rssi_pos = 2426
set osd_rssi_dbm_pos = 120
set osd_tim_2_pos = 2455
set osd_flymode_pos = 2401
set osd_current_pos = 2440
set osd_mah_drawn_pos = 2448
set osd_warnings_pos = 14602
set osd_avg_cell_voltage_pos = 2433
set osd_flip_arrow_pos = 2095
set osd_stat_max_spd = OFF
set osd_stat_battery = ON
set vtx_band = 1
set vtx_channel = 1
set vtx_power = 2
set vtx_freq = 5865
set vcd_video_system = NTSC
set gyro_1_align_yaw = 2700
set gyro_rpm_notch_harmonics = 1

profile 0

profile 1

profile 2

# restore original profile selection
profile 0

rateprofile 0

# rateprofile 0
set roll_rc_rate = 90
set pitch_rc_rate = 90
set yaw_rc_rate = 90
set roll_expo = 35
set pitch_expo = 35
set yaw_expo = 35
set roll_srate = 80
set pitch_srate = 80
set yaw_srate = 80

rateprofile 1

rateprofile 2

rateprofile 3

rateprofile 4

rateprofile 5

# restore original rateprofile selection
rateprofile 0

# save configuration
save
# 
$\endgroup$
4
$\begingroup$

After making sure that you have the RX_Loss beeper disabled, the next port of call would be to check your DShot config.

It may not be the beeper that is making the noise - there is a DShot beacon configuration that allows you to set your ESCs to beep in the case of RX_Loss - Id recommend you make sure you have that setting correct.

Edit: from your Diff All, it seems that beeper on RX_Loss May still be turned on, though I’m not sure.

$\endgroup$
2
  • $\begingroup$ I found the problem: RX_LOST was disabled, but RX_AUX wasn't. I have the beeper set to beep if i center a swich, and since that is the default in Betaflight, the beeper turn on because it thought the switch was in that position. $\endgroup$ Apr 18 '20 at 14:25
  • $\begingroup$ @HannesHultergård ah okay, glad you got it fixed $\endgroup$ Apr 18 '20 at 14:27
0
$\begingroup$

I found the problem: RX_LOST was disabled, but RX_AUX wasn't. I have the beeper set to beep if i center a swich, and since that is the default in Betaflight, the beeper turn on because it thought the switch was in that position.

I opened an issue about it here: https://github.com/betaflight/betaflight/issues/9717

$\endgroup$
1
  • $\begingroup$ Actually, I think it is working as intended. A channel without input defaults to the center. You can set a default value for the channel in betaflight, away from the center (1500). So it will not beep on RX loss. $\endgroup$
    – GreenT
    Apr 20 '20 at 10:56
0
$\begingroup$

Just turn off RX_Set (strange defined term)

$\endgroup$
1
  • 1
    $\begingroup$ Perhaps you could expand your answer to explain why you think this would solve the problem? $\endgroup$ Aug 4 '20 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.