1
$\begingroup$

I am running ardurover (title bar says "Mission Planner 1.3.77 build 1.3.8110.38294 ArduRover V4.4.0-dev (650e8652) on a Beaglebone Blue with Linux 5.10.140-bone-rt-r68. I have a GPS connected to the GPS connector, and I can see NMEA sentences when I stop ardurover and use minicom on /dev/ttyS2 at 9600 baud.

$GPGGA,165720.000,...,1,04,2.17,61.0,M,-17.1,M,,*6C
$GPGSA,A,3,23,15,18,10,,,,,,,,,2.38,2.17,0.98*03
$GPRMC,165720.000,A,...,0.19,149.90,021022,,,A*7D
$GPVTG,149.90,T,,M,0.19,N,0.36,K,A*35

However, Mission Planner always says no GPS. I've set the rates up for all ports except SERIAL0 to be SERIALX_BAUD: 9 and SERIALX_PROTOCOL: 5 (also tried 20), and SERIALX_OPTIONS: 0. I've restarted Ardurover and the entire board.

This is how it is being launched using systemctl:

SERIAL0="-A udp:192.168.0.27:14550"
SERIAL1="-C /dev/ttyS1"
SERIAL3="-B /dev/ttyS2"

/usr/bin/ardupilot/ardurover $SERIAL0 $SERIAL1 $SERIAL3

What am I missing?

$\endgroup$
2
  • 1
    $\begingroup$ You could try setting "SERIALX_PROTOCOL: 5" only on one port at a time. There is a note on ardupilot.org/rover/docs/common-flight-controller-wiring.html which states: "It is important that a GPS be connected to the first SERIALx port that has its SERIALx_PROTOCOL parameter set to “5” (GPS) since it will stop searching for GPS during bootup if not found on the first port configured for GPS protocol." So, if your GPS is not on the first port perhaps it is also not looking past the first port? $\endgroup$
    – Kralc
    Oct 3, 2022 at 15:06
  • $\begingroup$ I will attempt that and let you know. $\endgroup$
    – Steve
    Oct 3, 2022 at 20:15

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.