I have holybro X500 V2 kit with pixhawk 6x, which contains BLHeli S ESC. I usually have this drone turned on while I'm doing some programming on it. But after some time (10 minutes), its ESCs start to beep due to the inactivity of the motors.

How can I disable these beeps? Is there any parameter for this? I am using QGroundControl with PX4.

I know it is a valuable feature. If I lose my drone, it will help me find it, but I would like to turn this feature off for the time of development. Now I must always arm and disarm the drone to silence these beeps.


1 Answer 1


The inactivity beep is a feature of the ESC software, so you have to change that behavior in BLHeliSuite (or another compatible program, depending on your exact firmware variant).

The setting you want to change is the Beacon Strength. Simply turn it all the way down until it says "Off". Alternatively you can increase the Beacon Delay instead.

Oscar Liang has a good guide on how to flash and configure BLHeli_S ECSs that you might be interested in: https://oscarliang.com/flash-blheli-s-esc-firmware-fc-pass-through/


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.