4
$\begingroup$

I'm running a 500cm frame with 11" rotors. It flyes but the navigation modes seem to be a tip suprised, that INAV 3 seems to have some troubles, when I turn on the 3D GPS+baro position hold (NAVPOSHOLD). It beeps 3 times and does also drift away, but the docs don't mention anything about beeps. Has anybody an idea what the problem might be?

There is no obvious problem in the blackbox log (BTW can I get a full log of warnings?). All sensors calibrated properly and GPS 3D fix. Nav safe is green before takeoff.

$\endgroup$
2
  • 1
    $\begingroup$ Not a full answer by any stretch, but it might help direct your search to include "buzzer" as well as "beep", check out this page in the docs for the buzzer. $\endgroup$
    – anonymous2
    Jan 21 at 12:58
  • $\begingroup$ Well yes, but if you look for 'GPS' you don't get any infos if there is a bug or not? I guess it's not a arming sound, as the copter is already in air. Will see forward to get more live infos when setup FPV OSD. $\endgroup$
    – MaM
    Jan 22 at 15:15

1 Answer 1

0
$\begingroup$

I continued with some experiments and didn't got this error messages again. Esp. I installed a VTX and FPV Cam to check my settings via OSD and noticed some issues:

  • GPS ok and pos locked
  • You can't start with NAV modes enabled (knew it before but anyway)
  • re forced compass calibration and gyro calibration and checked against visual compass and virtual horizon
  • Horizon is less stabilazation controll than Angle, not sure if you can mix it with NAV modes?
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.