I can't get to get my FC (a JHE MCU F722 BT dual) into boot mode. I have tried:

  • under Linux (pop-os 21.04) and win 10
  • pressing the boot button when powering it up via USB
  • entering DFU mode via Betaflight firmware flasher.
  • betaflight activate boot loader/DFU
  • Inav configurator

What happens is: DFU is active, the right .hex file is found and ready. But when I try to flash it just doesn't. The green activity led keeps flashing.

There are only the following two errors:

  • Are Udev rules installed correctly (see docs for instructions) @ the top
  • initiating reboot at bootloader @ the bottom flash bar

I tried googling udev rules linux but didn't get very far.

Additionally I can connect normally and change anything I like (of course I haven't tried it all).

I am currently running configurator 10.7.0

It never used to be an issue and I have no idea since "when" this might have started.

  • 1
    $\begingroup$ Hey, welcome! Unfortunately, I'm having a hard time understanding what you're saying here. I get that you can't flash new firmware via DFU, but you haven't really told us what you're observing. What does Betaflight Configurator say while this is happening? Also, what are the "errors" you mentioned: where did they come from/where did you see them? $\endgroup$
    – ifconfig
    Nov 14, 2021 at 1:54
  • $\begingroup$ the errors is what betaflight config "says". at the top (above the honeycomb structure) it says: Udev rules installed correctly? , and at the bottom in the bar which would normally show the flashing process it gets stuck on " initiating rebooat at bootloader" $\endgroup$ Nov 14, 2021 at 13:46

1 Answer 1


You need to select "no reboot sequence" in the betaflight flash tool. The flasher by default tries to reboot the flight controller into DFU mode on its own, even if it already is in DFU mode.

From linux - modemmanager might be an issue. Kill that service. Ensure that your user (or sudo, but that complicates things) is a member of the "dialout" group. Only members of this group are allowed to access external devices.

  • $\begingroup$ thanks for your answer! no reboot sequence was selected of course. never the less i will make sure to pay attention to that when i try next. I will also kill the modem manager and make sure the dialout grouos are set as needed. I will keeo you updated over the weekend. never the less i feel i must mention that when i press the fc's boot button on power-up the activity led (green) flashes, which it shouldn't.. hence maybe there is an hardware issue rather then a software issue. but that is skipping over things. first things first. $\endgroup$ Nov 19, 2021 at 23:51
  • $\begingroup$ Unless the boot button itself is broken, then it's tough to have an issue. To be clear: you say "press". You need to hold the boot button while powering up the flight controller. The controller must go from off (no power) to on (plugged in) while the boot button is pressed $\endgroup$ Nov 21, 2021 at 2:04
  • $\begingroup$ yeah that is indeed what i did, sorry for the wording of the process. In the mean time i ] took the easy road and used a windows machine from a friend, on this machine things worked as intended.. which is good as i got the correct software on there but also because i know there is no other issue and that i should look for it in my linux setup so although i haven't fixed it yet i have strong feelings it is indeed modemmanager / dialout group related. thanks for your help. $\endgroup$ Nov 21, 2021 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.