6
$\begingroup$

I built a new quadcopter and was able to power up the drone with no problem when I finished. However, after flashing new firmware to my receiver and forgetting to disconnect the receiver wires from the flight controller during the process, my FC won't power on. I'm guessing I created a short when I was working on the receiver, but I want to make sure that the board is dead before a buy a new one.

Here's more information of my situation:

I'm using the Kakute F4 v2. Nothing heats up to very high temperatures on the board when I plug it in. I have a solid green power light, but no status light when I plug the board in. I measured the resistance between ground the the 3.3v pad on the FC, but the resistance was normal.

I'm not able to flash a new firmware to the board (windows doesn't even recognize the device anymore), and the impulse rc driver fixer did not work.

Is it safe to say that my board is dead and I should buy a new one, or is there something else I haven't tried yet?

$\endgroup$
2
  • $\begingroup$ Can you access the device in DFU mode? The stm32 bootloader is in ROM which means unless you damaged the hardware, the firmware side is recoverable. jump the boot pads or press the boot button on the FC while plugging in the board. I'd also recommend disconnecting everything from the FC at this point just to avoid any possible cross-contamination (though there should be none) $\endgroup$ Aug 3 at 13:46
  • $\begingroup$ I've tried booting into DFU mode with the board disconnected from everything else in the drone and all that happens is the board powers on (solid green power light) with no status light. Normally this would be a sign of the board entering DFU mode, but I don't have a status light even if I power the board without holding down the boot button. Also, my computer doesn't even connect to the board even though I'm using a cable that has had no trouble connecting my computer to other flight controllers. I'm guessing this is a sure sign that my board is fried? $\endgroup$
    – Luke Crimi
    Aug 4 at 3:04
3
$\begingroup$

Something similar happened to me only with a different cause, my quad crashed and the omnibus f4 v2 fried itself in the logic side but it could still power the esc and the 5v pads. So, I think sadly it is ok to say your board is dead.

$\endgroup$
1
  • $\begingroup$ Yeah, I figured this was the case. Thanks for making me 100% sure! $\endgroup$
    – Luke Crimi
    Aug 6 at 3:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.