I am using an HS-Series Holy Stone drone. I was able to get one video recording, but every subsequent video recording indexes the recording, but no duration time, and no actual video in it even when it says it has 23 Mb of video.

I am using VLC to view it since my MacBook Pro does not support .avi files.

What is going on?

Here is the VLC UI: enter image description here

Notice how the first recording shows 00:59 seconds, but each subsequent recording I tried, shows no Duration, yet at least one of them has 25MB...of what I have no idea.

  • 1
    $\begingroup$ Hrm. Could you elaborate on what you mean by "indexes the recording"? Maybe also show some screenshots of the SD card folder and VLC codec/metadata tabs. $\endgroup$ – ifconfig Dec 18 '20 at 1:22
  • 1
    $\begingroup$ Hrm. This either looks like either corrupted storage or a bum camera module. Could you try swapping out the SD card? Also, please post a comment when you respond to my comments so I get notified, I just happened to stumble across your question today and notice it was edited. $\endgroup$ – ifconfig Dec 21 '20 at 17:19
  • $\begingroup$ @ifconfig, I swapped out the SD card but with the second SD card there seems to be absolutely no data in it and I know i just did a recording. So either its the SD Cards or VLC or the drone, which does not help. Any suggestions on a better tool to view .avi files than LVC? I tried it again thinking perhaps I did not insert the SD card correctly, ensuring I did so the second time and still nothing. So after two different SD cards and things just get worse, I think its the drone. $\endgroup$ – Daniel Dec 25 '20 at 21:37
  • $\begingroup$ Can you confirm that the SD cards work properly in any other device? VLC is perfectly fine for .avis. $\endgroup$ – ifconfig Dec 25 '20 at 22:32
  • 1
    $\begingroup$ @ifconfig, I can accept that as an answer. It was one of the first drones I ever bought. Not that I didnt have my problems with the DJI Phantom 4. After about a year of light usage, the battery supposedly died. Honestly don't know if its the battery or the device, but DJI support believed it was the battery. $\endgroup$ – Daniel Dec 28 '20 at 3:31

Given that the drone camera is a cheap model from China, I think it's entirely possible that the camera modules is broken and could be outputting incorrectly terminated .avi files.

In earlier comments, you explain that no files are created when a known-good SD card is used to record video with the drone. My prior experience with camera modules for cheap Chinese-made RTF (ready-to-fly) drones has shown that there can be serious quality issues with the recorders. I used to have a Syma X5 model which I upgraded with the OEM camera module. The whole camera solution was shoddily made and implemented.

Based on the observations with the files created on the first SD card, one of which is unplayable but >0 bytes in size and the others which are entirely empty, this seems likely. Zero-size or otherwise corrupted video files are a common symptom of an incorrectly-terminated video stream. The .avi file format supports many kinds of video streams (wiki), but the drone camera most likely uses some kind of MPEG codec with interframe compression, which is more susceptible to corruption or incorrect stream termination than a full-frame uncompressed stream.


One common cause of incorrectly terminated video files is when you stop recording by just unplugging the drone battery. Ensure you're using the correct method to stop recording.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.