3
$\begingroup$

The story of how it broke;

I have a plane that I am/was building/fixing, and I was successfully able to make it fly...very shortly. Yes, I know that I launched it really bad and that I should've done a dozen things differently, but that's besides the point right now. After that crash, it was completely fine (except for the prop). I put on a new prop and tried again, with pretty much the same results, but I did get a bit higher and I had help launching it. After a second crash, I didn't have any more props of that size, and my 9050 props had a different hole size.

So I drilled some bigger holes in the 9050 props and put one on the next day, but the receiver wouldn't turn on. I figured I must've plugged something in wrong or left it in the sun and melted the electronics, so I ordered a new one, but that didn't even turn on either. Since it's not the receiver, I guess it has to be the esc, but it seems fine. It beeps when I plug in the battery and the motor will twitch just barely, so I don't think there's a problem there.

I'm really confused now, what is going wrong?

radio and first receiver link, second receiver link, esc and motor link, battery link.

$\endgroup$
14
  • $\begingroup$ With the battery removed, does the motor spin smoothly by hand? You may feel regular small detents from the magnets, which is normal, but the rotation should be easy and even all the way around. Also, if you have a multimeter, check for power out of the ESC to the receiver - when the propeller was stopped, it could have burned out the ESC (perhaps partially - e.g. one motor winding.) $\endgroup$
    – Kralc
    Nov 10 '20 at 15:01
  • $\begingroup$ @Kralc, yes the motor spins well by hand. I don't have a multimeter at the moment but i'll test that when I get one. $\endgroup$ Nov 10 '20 at 15:14
  • $\begingroup$ I have a few questions. Can you verify that the new receiver is bound to the transmitter and that the channels are matched correctly? Does any light turn on in the receiver when you plug in the battery? $\endgroup$
    – Jacob B
    Nov 10 '20 at 15:37
  • $\begingroup$ @JacobB, new receiver won't turn on with battery and esc which makes me think the esc is broken but it seems fine and beeps when i plug in a battery, so it is not bound yet. For old receiver a light would turn on but new receiver i have no idea but i think yes. $\endgroup$ Nov 10 '20 at 15:40
  • $\begingroup$ The light may only come one when the receiver links up to the transmitter. I wouldn't expect it to come on if it is not bound. The instructions should say what the light means. $\endgroup$ Nov 11 '20 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.