3
$\begingroup$

After last flight my Eachine Viswhoop stopped booting properly and arming (link to gfycat with sound). When connecting battery to drone I can hear FC beeping but don't get second set of "beeps" from ESCs. Also red led on flight controller starts blinking. First thing I checked configuration in Betaflight and noticed that tab "Modes" was empty and didn't have ARM or beeper configured. Thankfully I had my settings backed up so I was able to restore them. But after connecting to battery once again I still get the same result as earlier. BLHeli Configurator also sees all 4 ESCs but I cannot spin them. So, what can be problem here?

$\endgroup$
3
  • 1
    $\begingroup$ This isn't really the best forum for trouble shooting a particular issue, but hopefully we'll end up with a generic guide that will help others with a similar 'not-arming' problem. $\endgroup$ Oct 28 '20 at 10:46
  • 1
    $\begingroup$ Could you show us some pictures of the Betaflight configurator on the different relevant tabs? e.g. Configuration, Modes, etc. $\endgroup$
    – ifconfig
    Oct 29 '20 at 16:43
  • 1
    $\begingroup$ @ifconfig I checked Betaflight and found out that i had wrong protocol set up for my ESCs $\endgroup$
    – devaerial
    Nov 1 '20 at 10:37
2
$\begingroup$

There are a few things here. An empty Modes page isn't a problem, it just means you're in Acro mode all the time. You may want to set up Angle or Horizon for a whoop that will be flown indoors. Add beeper mode here too, if you want it.

There are a few things that could stop it arming. The easy way to tell is to turn on 'warnings' in the OSD, and see what it says in your goggles.

Common problems are:

  1. Not getting a signal from the receiver - check on the radio tab of BF.
  2. Incorrect lower bound on the throttle channel, because it wants to see the throttle closed when it arms.
  3. If you've set a maximum angle for arming, and the quad isn't sufficiently level.
$\endgroup$
2
  • 1
    $\begingroup$ I checked Betaflight once again and found out that I had wrong ESC protocol set up. When I changed protocol to DSHOT600 everything begin to work as intended. I think it could happen because I was hot-swapping batteries which probably triggered some reset function in FC. $\endgroup$
    – devaerial
    Nov 1 '20 at 10:36
  • $\begingroup$ That's one I've not heard of before! Well done for finding it. $\endgroup$ Nov 2 '20 at 8:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.