3
$\begingroup$

I have Kotleta 20 UAVCAN ESCs. When I trying to increase throttle, motors are vibrating like a jelly. How can I configure my ESCs via development port? What are best options for non vibrated flight? Is autotune good solution for that?Takeoff video

$\endgroup$
1
$\begingroup$

It might be a too high P-gain in the PID control loop. I assume you use Pixhawk so that document might be useful: PID tuning guide The oscillation is from what i see on the roll axis so the MC_ROLLRATE_P might be a parameter to look into.

Regarding the Debug port: Your escs have a Pixhawk Debug Mini connector and a serial console (with baudrate 115200 at 8 bit no parity 1 stopbit) should be available at pin 2 (tx) and 3 (rx) (pin 1: Processor voltage, pin 2: Console TX of ESC, pin 3: Console RX of ESC, pin 6: GND). See: Pixhawk Debug Mini

You will need to connect your serial interface with the voltage.matching your controller (probably 1.8 or 3.3V) and the out pin of your interface with the in pin of the ESC and vice versa. The commands you have available are described in the Sapog Reference Manual

Please provide more information about your setup to help others to help you with your question.

$\endgroup$
1
  • $\begingroup$ thank you for reply. i tried with direnc.net/30a-esc-fircasiz-motor-surucu this escs and there was no vibrating. now, i saw my p parameter is 0.0001 and my i parameter is 0.001 via sapog command line. $\endgroup$ Oct 24 '20 at 7:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.