3

I have a Diatione Mamba F405 MK2 and a HGLRC Forward VTX on my 6s race quad and I can't control the vtx using betaflight. The video transmission itself works fine, I just have to use the button on the board.

It says "Device Ready: No" in the betaflight configurator vtx tab and any parameters that I set there are ignored. In the OSD vtx menu the status line reads * UF ---- ----.

Here is my wiring and my ports configuration. It looks fine to me.

wiring diagram ports tab screenshot

And here is my full diff.

# version
# Betaflight / STM32F405 (S405) 4.2.0 Apr 29 2020 / 08:08:49 (b480103d4) MSP API: 1.43
# config: manufacturer_id: DIAT, board_name: FURYF4OSD, version: 3a35e73b, date: 2019-09-30T05:46:12Z

# start the command batch
batch start

board_name FURYF4OSD
manufacturer_id DIAT

# name: Sea Breeze

# beeper
beeper -ON_USB

# beacon
beacon RX_SET

# serial
serial 0 64 115200 57600 0 115200

# aux
aux 0 0 0 900 1300 0 0
aux 1 1 1 1300 1700 0 0
aux 2 13 2 1700 2100 0 0
aux 3 35 1 1800 2100 0 0

# vtxtable
vtxtable bands 6
vtxtable channels 8
vtxtable band 1 BOSCAM_A A CUSTOM  5865 5845 5825 5805 5785 5765 5745 5725
vtxtable band 2 BOSCAM_B B CUSTOM  5733 5752 5771 5790 5809 5828 5847 5866
vtxtable band 3 BOSCAM_E E CUSTOM  5705 5685 5665 5645 5885 5905 5925 5945
vtxtable band 4 FATSHARK F CUSTOM  5740 5760 5780 5800 5820 5840 5860 5880
vtxtable band 5 RACEBAND R CUSTOM  5658 5695 5732 5769 5806 5843 5880 5917
vtxtable band 6 IMD6     I CUSTOM  5362 5399 5436 5473 5510 5547 5584 5621
vtxtable powerlevels 5
vtxtable powervalues 25 50 100 200 400
vtxtable powerlabels 25 50 100 200 400

# master
set dyn_notch_width_percent = 0
set dyn_notch_q = 250
set dyn_notch_min_hz = 70
set dyn_notch_max_hz = 350
set acc_calibration = 62,-10,158,1
set min_check = 1005
set max_check = 1995
set rssi_channel = 16
set rssi_src_frame_errors = OFF
set rc_smoothing_derivative_type = PT1
set fpv_mix_degrees = 25
set dshot_bidir = ON
set ibata_scale = 115
set beeper_dshot_beacon_tone = 3
set small_angle = 180
set pid_process_denom = 2
set osd_vbat_pos = 450
set osd_rssi_pos = 2106
set osd_tim_2_pos = 2519
set osd_flymode_pos = 2082
set osd_throttle_pos = 2466
set osd_current_pos = 2505
set osd_mah_drawn_pos = 2512
set osd_warnings_pos = 14729
set osd_avg_cell_voltage_pos = 2498
set vtx_band = 1
set vtx_channel = 1
set vtx_power = 3
set vtx_freq = 5865
set gyro_1_align_yaw = 1800
set name = Sea Breeze

profile 0

# profile 0
set dyn_lpf_dterm_curve_expo = 6
set vbat_sag_compensation = 100
set anti_gravity_gain = 5000
set iterm_relax = RPY
set p_pitch = 32
set d_pitch = 27
set p_roll = 29
set d_roll = 25
set p_yaw = 31
set d_min_roll = 16
set d_min_pitch = 18

rateprofile 0

# rateprofile 0
set rates_type = QUICK
set roll_rc_rate = 120
set pitch_rc_rate = 120
set yaw_rc_rate = 120
set roll_srate = 90
set pitch_srate = 90
set yaw_srate = 90

# end the command batch
batch end

I have redone all solder joints and checked for continuity with my multimeter. Is my wiring maybe just wrong? Or is my vtx broken?

(I'm using a betaflight 4.2 rc version, but I've also had this issue with 4.1)

Edit: I contacted the HGLRC support and they told me that IRC Tramp is indeed the correct protocol and they gave me a vtx table which was identical with mine.

  • I don't think IRC Tramp is the right setting in the Ports tab. I believe the HGLRC Forward VTX uses SmartAudio and not the Tramp protocol. – ifconfig Jun 6 at 19:16
  • Thanks for your reply. Unfortunately the manual doesn't say which protocol the VTX is using... And when I enable the SmartAudio blackbox debug mode, all 4 debug channels are at 0. That's why I assumed it must be IRC Tramp. In case it uses SmartAudio, what could be the reason that it doesn't work either? – lukad Jun 6 at 19:28
  • Well, BF 4.1 introduced vtxtables that need to be manually configured before using SmartAudio, which could be the issue. See Joshua Bardwell's video on the topic here: youtube.com/watch?v=VRQJJTyHNJw – ifconfig Jun 6 at 19:48
  • I know how to set up vtx tables for SmartAudio. Before you can load the right vtx table you need to know which SmartAudio version the vtx uses. But like I said the SmartAudio debug mode shows nothing at all. I just tried using the SmartAudio vtx tables from the Betaflight wiki anyway. But still nothing. – lukad Jun 6 at 20:10
  • Huh, well I'm sorry to say that I'm stumped. I don't have much experience debugging FC→VTX communications. – ifconfig Jun 6 at 21:51
1

Since you confirmed that the protocol+vtx table is correct I'd focus on the physical connection. One explaination would be that the signal is disturbed and the vtx has a hard time decoding it.

Try to disconnect all other components and focus just on the fc+vtx. Try to isolate the SMA connector of the vtx from any carbon parts/metal parts of the frame. Another option is to twist the cables going from the fc to the vtx. You could also add capacitors to the power supply.

If nothing works I'd try a different vtx and check if the problems carry over the new vtx. Adding a phono of your wiring could also help to identify the issue.

| improve this answer | |
  • Sound advice, but I had already made sure that everything is isolated. The SMA connector is only touching my TPU mount and I have a 470uF 37V capacitor on my power supply. Using a different VTX did the trick. – lukad Jun 10 at 13:48
0

I received my new VTX (Rush Tank) today and I plugged it straight into the same connector that I had used for the other VTX, changed my ports and VTX table accordingly and it just works.

My best guess is that the old VTX is simply defective, although I couldn't see any damaged parts on the board.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.