3
$\begingroup$

I have being trying to establish Serial Communication connection between APM 2.8 and Raspberry Pi Board. But the connection is not being recognized in the Raspberry Terminal Console. enter image description here Configuration Setup:

Model: Quad-copter

Type: X

Flight Controller: APM 2.8 FC

Companion Computer: Raspberry Pi 3 Model B+

I have being digging through web archives and found only MAVProxy Connection with Pixhawk & Raspi. Any help, advice, or guidance would be helpful.

Current Refereed:Here

$\endgroup$
2
$\begingroup$

There are a bunch of problems which need to be overcome when using the RPi GPIO serial port.

  1. The RPi normally runs a login process on the serial port, this will need to be disabled.
sudo systemctl stop serial-getty@ttyS0.service
sudo systemctl disable serial-getty@ttyS0.service

you will also need to edit /boot/cmdline.txt and remove this part: console=serial0,115200

  1. On a RPi 3/4 the port name in linux if different to the port name used on older RPi's.

  2. If using a recent image, the serial port is disabled in the config.txt by default. To fix this you need to edit /boot/config.txt and add the following line.

enable_uart=1

This page Configuring The GPIO Serial Port On Raspbian Jessie and Stretch Including Pi 3 and 4 has a very good writeup on how to get it all working.

Also make sure that you are connecting RX on the RPi to TX on the APM and vice-versa.

| improve this answer | |
$\endgroup$
  • $\begingroup$ On recent images, there is the potentially easier option to use sudo raspo-config -> 5 Interfacing Options -> P6 Serial -> "Would you like a login shell to be accessible over serial?" No then exit and reboot. $\endgroup$ – Kralc May 28 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.