My new dji Mavic Air 2 arrived, but it was not connected to the remote control as it is supposed to be connected upon arrival. I then tried connecting it manually following the on-screen instructions of the DJI Fly App, but the Mavic Air 2 doesn't go into the pairing mode when I press the on/off button for 4 seconds or more.

The connection between the App and RC works. The drone is turned on, it does its self-test and briefly beeps. The 4 LEDs are constantly on. Holding down the power button makes it flash slowly, but there is no beep and the LEDs will stop flashing when I release the button.

Is there any other way to reset / pair the drone to the remote control?

  • $\begingroup$ I tried that and it did not work. This all happened after I updated firmware. Any suggestions $\endgroup$
    – Thomas
    Commented Jun 28, 2023 at 1:07

2 Answers 2


According to page 36 of the DJI Mavic Air 2 manual the aircraft should be linked to the remote controller on arrival.

If not, you should follow these steps:

  1. Power on the remote controller and the aircraft.
  2. Launch DJI Fly.
  3. In camera view, tap (three dots) and select Control and Connect to Aircraft.
  4. Press and hold the power button of the aircraft for more than four seconds. The aircraft beeps once indicating it is ready to link. The aircraft beeps twice indicating linking is successful. The battery level LEDs of the remote controller will glow solid.

I think the issue was you didn't try to link it through the DJI Fly app.

  • $\begingroup$ Thanks for your help! I just tried it again – the RC is beeping and looking for the drone. Unfortunately on the drone side nothing happens when I press the power button for more than 4s. I can switch the drone on, cooling fans are audible and the done does it's self test, but when holding the button it won't beep. The battery level LEDs glow solid all the time, but it is not connected to my remote. $\endgroup$
    – youngpilot
    Commented May 23, 2020 at 14:26
  • $\begingroup$ @youngpilot Is your remote control charged and close to the aircraft? $\endgroup$
    – user149
    Commented May 23, 2020 at 14:35
  • $\begingroup$ Yes, it is fully charged and directly next to the drone. $\endgroup$
    – youngpilot
    Commented May 23, 2020 at 14:43
  • $\begingroup$ @youngpilot maybe you can try linking with a different device? Have you followed all the steps here: heliguy.com/blog/linking-the-remote-controller-dji-mavic-air $\endgroup$
    – user149
    Commented May 23, 2020 at 14:47
  • $\begingroup$ You mean using another smartphone? The DJI Fly App shows that the RC is connected to the smartphone. Otherwise, I don't have another drone at hand nor another compatible remote. The steps in the link are for the DJI Go 4 App. These steps seem to be different in the DJI Fly app. $\endgroup$
    – youngpilot
    Commented May 23, 2020 at 14:49

In this case there is no way to reset the connection. It is a defective unit. I sent it back and ordered a new one.

Result of chat discussion with @Daniil:

I couldn't connect the drone to the RC nor to a PC/Mac (it never showed up in the DJI Assistant for Mavic nor in the usb device list), and therefore not reset or update the drones firmware. @Daniil and me concluded, the drone is defect. I sent it back to Amazon and ordered a new one.

I also opened a support ticket at DJI, describing the problem. So far I got no response, but hope they use this feedback to fix the bug and improve their QA.

  • $\begingroup$ Thanks for posting this - let me know how the new drone goes $\endgroup$
    – user149
    Commented May 24, 2020 at 12:10
  • 1
    $\begingroup$ The new drone works flawlessly! As supposed, it was connected to the RC out of the box. Apparently the first one was indeed a defective unit. $\endgroup$
    – youngpilot
    Commented Jun 9, 2020 at 10:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.