11

I just finished building my first quadcopter/drone and it flips when I try to take off.

What could be wrong?

What troubleshooting steps should I take to fix it?

12

There are several things that can be causing this with different likelihoods.

The first thing to check is - are your propellers on correctly? It is an easy mistake to make and always worth a check.

The next thing to check is that all of your motors are working correctly. Start by spinning each of the motors by hand and see if anything fella obviously wrong, for example, a magnet out of place. If nothing feels wrong, remove the props and individually spin up the motors in Betaflight to test them.

The next port of call is your gyro. Plug your quad into Betaflight or whatever firmware you use and move it around - does the virtual representation of the quad match up with your movements in real life? If not, that is almost certainly the cause.

Now make sure the motors spin in the correct direction and the correct position to match the graphic on your configurator by using the motors tab with the propellers off

If all of these have failed, swap two of your motors and see if the quad flips in the same direction. If the problem follows the motor, you have a faulty motor. If the problem stays in the same place, you likely have a faulty ESC.

If your ESC is not faulty and your motors are also fine, it is also possible that your resource mapping is incorrect. In the Betaflight CLI, type ‘resource’ and ensure that the correct pin from the microcontroller is assigned to the correct motor.

You should also check that your motor direction is correct in Betaflight, and your motors are spinning in the expected directions in real life. If not, that can be fixed either in BLHeli or by swapping round any 2 wires from the motor to ESC.

| improve this answer | |
  • This would be a perfect answer if it also included wrong motor order and motor spinning in the wrong direction as possible issues. – tavis Apr 15 at 0:24
  • @tavis thank you, I’ll add that now. – Drones and Whatnot Apr 15 at 0:25
4

In my experience, the causes of this problem are (in order of probability )

  1. One or more propellers are on wrong.

  2. One or more motors are spinning in the wrong direction.

  3. Flight controller orientation is wrong (mounted facing the wrong direction)

  4. Motor order is wrong (ie. physical location of motors 1-4 does not match up with what the flight controller expects )

How to solve :

Issue 1. On standard rotation quads (props in) the Front Left and Back Right props should create thrust when spinning clockwise. Front Right and Back Left counterclockwise. Make sure the props will create a downward thrust when spun in their corresponding directions.

Issue 2. On standard rotation quads you will need to spin up each individual motor (eg in Betaflight configurator) and make sure it is spinning the proper direction. See Issue 1. for which direction that should be. To do this take off any propellers, connect to Betaflight and plug in a battery. Go the Motors tab in Betaflight and read the warning and click the "props are off" slider. Now slightly move up the slider for motor 1-4 one at a time and feel with your hand for proper direction. If you find a motor going the wrong direction make a note of which one it is (there might be more than 1). To change the direction of any motor use BLHeli configurator for BLheliS ESCs and BLheli Suite for BLHeli32 ESCs. Google search this for more details on how to reverse the motor direction. Alternatively, you can swap any two motor wires at the ESC connection to change the direction.

This post has a very detailed explanation and diagrams What process should I use to ensure my motors are spinning the correct direction when using Betaflight

Issue 3: Look on your flight controller for an arrow pointing in a certain direction. It should be pointing to the front of the quad. If it is not then this is probably your issue. You can also confirm this issue by connecting your FC configurator (eg Betaflight) and looking at the setup screen where you should see a 3d model of a quad that moves around when you physically move the quad around. If the movement of 3d model doesn't match how you move the physical quad then you have an alignment issue. To fix you can either physically rotate the FC so that the arrow points forward or you can set a board rotation in the Betaflight configuration page.

Issue 4: To figure out if this is your issue, follow the motor spinning steps in the solution for Issue 2. When spinning up a motor, make sure it's physical location matches the motor map picture in your configurator. In Betaflight the order should be 1: Back Right, 2: Front Right, 3; Back Left, 4: Front Left. If you move the slider for motor 1 and the Front right motor spins, you have a motor order problem. This can happen if using a 4in1 ESC and two of the motor signal wires got swapped or if the ESC has a motor order that doesn't match what Betaflight expects. The easiest way to fix is to change the motor signal wires so that the order is correct.

| improve this answer | |
  • In general, answers which only contain a link to another off-site resource are frowned upon. Please attempt to paraphrase the content of your source here. – ifconfig Apr 15 at 0:21
  • Added video summar. – tavis Apr 15 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.